The Godot Q&A is currently undergoing maintenance!

Your ability to ask and answer questions is temporarily disabled. You can browse existing threads in read-only mode.

We are working on bringing this community platform back to its full functionality, stay tuned for updates. | Twitter

+1 vote

I want to localize my game into different languages, starting with german. I setup a csv-file with the translations and import it. The english text is shown. Everything works fine so far.
But if I use the german translation the special characters (üöäßÜÖÄ) mess up the text. Most of them only mess up the text they are used in (Zuräck --> Zurr), but the "ü" even messes up all localization keys which follow in the locafile and only the keys appear in the game. The font I am using contains the characters.
Any idea how to solve this problem? Do I have to replace the characters by some magic stuff? Any import options I missed?

My loca.csv

in Engine by (13 points)

1 Answer

+1 vote

Maybe your file is in ANSI.
You have to save it with e.g. Notepad as UTF-8.

But it seems to me as currently in Godot 2.1.2 the Import / Translation function is crashing the Godot editor.
In Godot 2.1.1 it worked.

by (78 points)
Welcome to Godot Engine Q&A, where you can ask questions and receive answers from other members of the community.

Please make sure to read Frequently asked questions and How to use this Q&A? before posting your first questions.
Social login is currently unavailable. If you've previously logged in with a Facebook or GitHub account, use the I forgot my password link in the login box to set a password for your account. If you still can't access your account, send an email to [email protected] with your username.