The Godot Q&A is currently undergoing maintenance!

Your ability to ask and answer questions is temporarily disabled. You can browse existing threads in read-only mode.

We are working on bringing this community platform back to its full functionality, stay tuned for updates. | Twitter

0 votes

I have this problem:
As you can see, a huge part of the map is blackened for some reason. I think it is related to the distance. Godot blackens the view after some distance. How can I fix this. I want everything to be seen in the map.

Godot version 3.3
in Engine by (16 points)

1 Answer

0 votes

You can either divide your map into chunks using blender or any 3D software ,
Or go to project settings -> Rendering -> Limits -> Max Lights Per Object , and make it a higher number (Will cause performance drop if u have many lights and objects)

by (298 points)
Welcome to Godot Engine Q&A, where you can ask questions and receive answers from other members of the community.

Please make sure to read Frequently asked questions and How to use this Q&A? before posting your first questions.
Social login is currently unavailable. If you've previously logged in with a Facebook or GitHub account, use the I forgot my password link in the login box to set a password for your account. If you still can't access your account, send an email to [email protected] with your username.