This site is currently in read-only mode during migration to a new platform.
You cannot post questions, answers or comments, as they would be lost during the migration otherwise.
+1 vote

Hi there.
I'm currently working on my first project in Godot.
The project is aiming at different platforms (X11,Windows,Android)
and i noticed that sometimes the physicsengine (3d) is behaving differently across the platforms. For example:

I have a RigidBody object that gets thrown up in the air by another object (ball enters platform - platform moves upwards to throw the ball up).
On X11 it behaves as expected but on Android the ball gets thrown up in the air way higher than on X11.

Is this a bug , or am i missing something?


in Engine by (22 points)

Is there an FPS difference between the two? Maybe that affects physics somehow (but theoretically it shouldn't).
If you think this as serious gameplay issues, you could search or open an issue on Github about this.

You are right. It seems to be related to the FPS.
I tested it across multiple Android devices (low end to High end).
On the Desktop the testscene is running at 60 fps constant and on the (sort of) low end devices, the fps drops to ~40. If i set settargetfps AND the physics fixed_fps to 40, the problem is gone. Just limiting the Game FPS doesn't make a difference.

But in my opinion, that shouldn't be the case. Obiously i don't know on which device a player will run the game on. Because of that, the engine should take care of this.

Btw. The Godot Version im running is the 2.1.1 stable (official build)

Thanks Zylann for pointing me in that direction :)

Ps: Weird..... The commenting function in here automatically removes the underscores at settargetfps but leaves them intact at fixed_fps ;D

Is weird, if you open a issue, try to add an example project and details on the devices that are showing the issue, could be related to the way server threads work.

I already opened an issue on github. I will prepare an example scene as soon as i am back at my working computer tonight.

1 Answer

+1 vote
Best answer

OK. Never mind. Found the Problem after i got a comment on Github.
I'll leave the solution here, in case someone else makes the same "beginner" mistake.

I just forgot to set the animation players process mode from "idle" to "fixed".
To be honest, i never noticed that this option is there.

Now the "Bug" is fixed :)

(feels a little dumb now) *gggg

Thanks for the comments anyway.


by (22 points)
edited by
Welcome to Godot Engine Q&A, where you can ask questions and receive answers from other members of the community.

Please make sure to read Frequently asked questions and How to use this Q&A? before posting your first questions.
Social login is currently unavailable. If you've previously logged in with a Facebook or GitHub account, use the I forgot my password link in the login box to set a password for your account. If you still can't access your account, send an email to [email protected] with your username.