+1 vote

I am trying to export project to android, but keep getting 'apksigner' returned with error #1

OS: Windows 10

I followed https://docs.godotengine.org/en/stable/getting_started/workflow/export/exporting_for_android.html#download-the-android-sdk documentation

I have searched for solutions and tried:
- installing tools with just the versions specified in documentation
and uninstalling other versions
- downgraded to build tools 29.0.3
- adding and removing debug.keystore, username and password in export settings
- using my previous keystore file and generating a new one and using that

None of the above has worked.

My collegue can export the same project on his PC and I have the same tool versions and settings as he has, but I still have the error.

My editor settings:
Editor settings

Export settings:
Export settings

I am new to Godot and would appreciate any help.

Godot version 3.3.
in Engine by (17 points)

3 Answers

0 votes

Open JDK (version 8 is required, more recent versions won't work)

Creating key for debug
keytool -keyalg RSA -genkeypair -alias androiddebugkey -keypass android -keystore debug.keystore -storepass android -dname "CN=Android Debug,O=Android,C=US" -validity 9999 -deststoretype pkcs12

Creating key for release
keytool -v -genkey -keystore mygame.keystore -alias mygame -keyalg RSA -validity 10000

This keystore and key are used to verify your developer identity, remember the password and keep it in a safe place!

Take a look here Link

by (100 points)

You don't need release key for debug. And you only need provide key at Export panel or Editor Settings.

Set up Java_home variable and ran sdkmanager command and tried to export again, still the same exporting error.

I am providing the key in editor settings, but have also tried providing it in export settings and it did not solve the problem.

I have no idea how to help you at this point. Maybe screen share ?

Screen share might help, but I can't do that now. Maybe sometime later

Understandable sure.

0 votes

Fixed the problem by renaming folder in the path to the project folder. Original one had Latvian symbols in it (Programmēšana), renaming it to "Programming" seems to have fixed the apksigner error.

by (17 points)
0 votes

Had the same issue, fixed by using JAVA 11 instead of 12 and using android studio to uninstall SDK 29 and below. Works well with SDK 30 and up. this is on Godot 3.4.4

by (16 points)
Welcome to Godot Engine Q&A, where you can ask questions and receive answers from other members of the community.

Please make sure to read Frequently asked questions and How to use this Q&A? before posting your first questions.
Social login is currently unavailable. If you've previously logged in with a Facebook or GitHub account, use the I forgot my password link in the login box to set a password for your account. If you still can't access your account, send an email to [email protected] with your username.