0 votes

The problem:

I am using isometric view. The problem is that the pathfinding which I set to to the texture is not aligned to the position of the tile. I might be missing something, please help.

Godot version 3.2.3-stable
in Engine by (64 points)

Did you change the texture offset or shape offset properties in the Tileset editor?

1 Answer

0 votes
Best answer

There are 2 solutions to the problem!

  1. Don't drag and drop the textures into a Node2D scene, but rather, setup the resource by hand, and add the Navigation nodes to each single tile. This solution is slow and bad.
  2. After you dragged the textures to the scene, turn off the centered property in the inspector. I also put their transform to Vector2(0, 0) which you might or might not have to do.
by (64 points)
Welcome to Godot Engine Q&A, where you can ask questions and receive answers from other members of the community.

Please make sure to read Frequently asked questions and How to use this Q&A? before posting your first questions.
Social login is currently unavailable. If you've previously logged in with a Facebook or GitHub account, use the I forgot my password link in the login box to set a password for your account. If you still can't access your account, send an email to [email protected] with your username.