The Godot Q&A is currently undergoing maintenance!

Your ability to ask and answer questions is temporarily disabled. You can browse existing threads in read-only mode.

We are working on bringing this community platform back to its full functionality, stay tuned for updates. | Twitter

0 votes

I've been having an issue with Light 2D not lighting the area correctly. <-- Link to gif of what it looks like, as well as three other images of the scenes

So I have a player with a light 2D as it's child, and an auto tileset that has all its occlusions set, but for some reason the light shines on just the wall. Has this happened to anyone else, and if so, how would one fix this?

Godot version 3.3.3
in Engine by (50 points)

2 Answers

0 votes
Best answer

I figured it out, the issue was that I moved the light 2D, which made it's shadow a bit weird. So instead I moved it by its offset, and that seems to fix the issue I was having

by (50 points)
+1 vote

not sure that's what you are looking for, but the light2D has a range_height parameter, try increasing it to >0

by (1,514 points)
Welcome to Godot Engine Q&A, where you can ask questions and receive answers from other members of the community.

Please make sure to read Frequently asked questions and How to use this Q&A? before posting your first questions.
Social login is currently unavailable. If you've previously logged in with a Facebook or GitHub account, use the I forgot my password link in the login box to set a password for your account. If you still can't access your account, send an email to [email protected] with your username.