+2 votes

I saved a png with transparent background but when imported and dragged into the sprite node it still shows the transparent background (it is not invisible). Any Idea, I have tested many different pngs from google?

Godot version 3.2
in Engine by (14 points)

I just tried it. It works. Maybe your images are not transparent. Remember, google results are not transparent just because you search png. download this image from download option given below:

2 Answers

+1 vote

Maybe you still downloaded a picture not with a transparent background, but just a background with squares that show that the background is supposedly transparent.

Godot does a great job with this, without any additional intervention.

If the standard icon.png which is in the root of your project looks good with these actions (and you don't see "squares" on its corners). Then you just choose the wrong images on google =/

by (162 points)
0 votes

Try different SRGB settings.

by (889 points)
Welcome to Godot Engine Q&A, where you can ask questions and receive answers from other members of the community.

Please make sure to read Frequently asked questions and How to use this Q&A? before posting your first questions.
Social login is currently unavailable. If you've previously logged in with a Facebook or GitHub account, use the I forgot my password link in the login box to set a password for your account. If you still can't access your account, send an email to [email protected] with your username.