The Godot Q&A is currently undergoing maintenance!

Your ability to ask and answer questions is temporarily disabled. You can browse existing threads in read-only mode.

We are working on bringing this community platform back to its full functionality, stay tuned for updates. | Twitter

0 votes

I'm designing a desktop application using Godot. I'm aware that it's for making games, but creating GUI with it is so easy.

There are a lot of threads about fonts on a high-DPI screen, but, even after reading those, I still have trouble with it.

  • If I use the default font, the text on controls is pixelated.
  • If I use a custom dynamic font in the theme of the root control, it is the same thing as above.
  • If I then set the Mode/Aspect to 2d/Expand, the text is crisp. But its size changes when I resize the window.

Is there a way to have a crisp font on low- and high-DPI screens without having it changing size with the window?

Basically, I'm trying to replicate the behavior of the Godot editor itself.

Godot version 3.3.3
in Engine by (17 points)

Were you able to solve it? I'm looking for the same answer

Yes, it works now. Since version 3.4 actually.
Just set Stretch Mode to disabled and Stretch Aspect to expand.

Please log in or register to answer this question.

Welcome to Godot Engine Q&A, where you can ask questions and receive answers from other members of the community.

Please make sure to read Frequently asked questions and How to use this Q&A? before posting your first questions.
Social login is currently unavailable. If you've previously logged in with a Facebook or GitHub account, use the I forgot my password link in the login box to set a password for your account. If you still can't access your account, send an email to [email protected] with your username.