This site is currently in read-only mode during migration to a new platform.
You cannot post questions, answers or comments, as they would be lost during the migration otherwise.
+1 vote


I am using a Tileset to create a hexagonal map.

When I use the default zooming of (1, 1) I get the following image as I expect:


But when I update the zoom with mouse scrolling on some zoom levels (not all) i get some black lines between the hexagons:


I already set the options:

GPU PixelSnap to true
Stretch Mode to Viewport
Aspect to Keep
Doubled the TileMap quandrant value

But it doesn't change anything. Nay suggestions on what to try next ?

Godot version 3.4
in Engine by (36 points)

1 Answer

+2 votes
Best answer

I had the same problem when making a hex map, my solution was to just decrease the size of the tiles, NOT THE ART by 1 pixel on all sides, and turn on GPU pixel snap. That fixed it.

by (663 points)
selected by
Welcome to Godot Engine Q&A, where you can ask questions and receive answers from other members of the community.

Please make sure to read Frequently asked questions and How to use this Q&A? before posting your first questions.
Social login is currently unavailable. If you've previously logged in with a Facebook or GitHub account, use the I forgot my password link in the login box to set a password for your account. If you still can't access your account, send an email to [email protected] with your username.