The Godot Q&A is currently undergoing maintenance!

Your ability to ask and answer questions is temporarily disabled. You can browse existing threads in read-only mode.

We are working on bringing this community platform back to its full functionality, stay tuned for updates. | Twitter

0 votes

I am trying to make my background/foreground clouds of my scene have a parallax scroll effect for a game I am trying to make. The issue I am having with it is I am getting this pop in effect when it seems to reach its width bounds. I have searched and messed with settings based off on similar posts but I haven't been able to fix it. I recorded a small clip of it to show what it looks like (basically happens at the 10 second mark but I shortened it in the gif to save peoples time).

Gif of pop in -

This is my project settings / window settings -

Foreground Clouds Sprite Settings -

Background Clouds Sprite Settings -

Background Clouds Import Settings -

Foregrounds Clouds Import Settings -

Script example:

extends ParallaxLayer

export(float) var CLOUD_SPEED = -15

func _process(delta) -> void:
    self.motion_offset.x += CLOUD_SPEED * delta

This is from BitBrains Parallax Background Tutorial.

Any help would be appreciated.

  • TheSnowmannDev
Godot version 3.4.2
in Engine by (22 points)

can you send the properties of the parallaxlayer?

BackgroundClouds ParallaxLayer settings -
ForegroundsClouds ParallaxLayer settings -
YouTube Example of what is happening -

2 Answers

0 votes
Best answer

I figured out the issue. Because my sprites were 240x135 and I was using the GSL2 project setting it did not like that when I set the repeat to enabled because it couldn't scale in a power of two. Once I swapped to GSL3 the issue was solved. I also changed my Project Window > Size > Width to 240 and Height to 135 with the Test width and height of (240x4) x (135x4).

by (22 points)
edited by
0 votes

You have to import the textures with the flag "repeat" set to enabled in the import tab
Press "reimport" after setting repeat to enabled as shown.

by (59 points)

They are set to repeat. You can see in the import settings pictures that I had it set to enabled.

Welcome to Godot Engine Q&A, where you can ask questions and receive answers from other members of the community.

Please make sure to read Frequently asked questions and How to use this Q&A? before posting your first questions.
Social login is currently unavailable. If you've previously logged in with a Facebook or GitHub account, use the I forgot my password link in the login box to set a password for your account. If you still can't access your account, send an email to [email protected] with your username.