0 votes

Filtered text in Godot :(
How do I disable texture filtering / anti-aliasing for label text in Godot? I can re-import sprites to make them nice and crispy, but the text is still all blurry. Or if impossible for label text, what are some alternatives?

Godot version Godot Engine v3.3.4.stable.mono.official [faf3f883d]
in Engine by (43 points)

Are you using the default font for the engine? If you're using a different font, have you changed the settings for the font?

I was using the default font yeah, creating a new font, and then loading a font as a resource made the filtering/aliasing go away, thanks.

1 Answer

+1 vote
Best answer

I would recommend using a dynamic font, and increasing it's size. It looks here like you're either trying to scale the font, or you're just zoomed in too much.

If you're looking for a pixel art type of effect you should look into project settings, there's a few settings there that are relevant (like anti-aliasing and all that).

by (1,346 points)
selected by

I am zoomed in a lot for emphasis, yes, but the issue wasn't that the filtering/aliasing was "too blurry", but rather I didn't want filtering/aliasing AT ALL. Anyways, thanks, it seems that when creating a new bitmap font or dynamic font, and loading an .otf/.ttf font for the font data, the filtering/aliasing goes away. There appears a "use filter" option that's off by default when doing that.

I couldn't find anything within the project settings that I think would help except maybe "gpu pixel snap" under General\Rendering\2d, which sounds like it could be useful for moving text (if I'm correctly understanding what that option does), thanks.

Welcome to Godot Engine Q&A, where you can ask questions and receive answers from other members of the community.

Please make sure to read Frequently asked questions and How to use this Q&A? before posting your first questions.
Social login is currently unavailable. If you've previously logged in with a Facebook or GitHub account, use the I forgot my password link in the login box to set a password for your account. If you still can't access your account, send an email to [email protected] with your username.