This site is currently in read-only mode during migration to a new platform.
You cannot post questions, answers or comments, as they would be lost during the migration otherwise.
+1 vote

Hi. I have a skybox that looks normal on the editor and when exported to pc but when it's on android it became blocky and pixelated even though I have the sky's texture filtering turned on. What should I to do have it look the same as in the editor?


in Engine by (15 points)

1 Answer

0 votes

This is likely because VRAM compression is used for the panorama sky texture. This compression looks worse on Android when GLES2 is used as only ETC1 is available there. To resolve this, select the panorama sky texture in the FileSystem dock, go to the Import dock, set the compression mode to Lossless then click Reimport.

by (12,908 points)

Hi. Thank you for your reply. I have checked the panorama sky texture's import settings and confirmed that it is indeed set to lossless. I noticed though that I am using godot version 3.3.2 with v3.2.1's build templates. Not sure if that would cause an issue, but I'll try to see once I updated them to the latest release

Update: After updating everything to godot 3.4.2 together with the build template, the issue is still there. Switching between gles 2 and 3 also doesn't seem to do anything.

Try enabling Allow Hidpi in the Project Settings then export to Android again.

Tried enabling Allow Hidpi today but unfortunately nothing changed

Welcome to Godot Engine Q&A, where you can ask questions and receive answers from other members of the community.

Please make sure to read Frequently asked questions and How to use this Q&A? before posting your first questions.
Social login is currently unavailable. If you've previously logged in with a Facebook or GitHub account, use the I forgot my password link in the login box to set a password for your account. If you still can't access your account, send an email to [email protected] with your username.