This site is currently in read-only mode during migration to a new platform.
You cannot post questions, answers or comments, as they would be lost during the migration otherwise.
+2 votes

I'm trying to draw a straight Line2D and make it appear/disappear with a Tween Node. Problem is, my line is everything BUT straight. I can clearly see the individual sections of it and for some reason they aren't perfectly aligned to each other. But they totally should, since I'm drawing straight from (0,0) to (1000,0). enter image description here

I haven't touched the project settings much, except for stretch, where I choose mode: 2d and aspect: keep. I also checked Hidpi

Godot version 3.4.2
in Engine by (23 points)

1 Answer

+1 vote
Best answer

Alright, I actually solved this a few minutes ago. Just turn on "antialiased" in your Line2D-Node under "Border" and your line will be smooth as silk.

by (23 points)
Welcome to Godot Engine Q&A, where you can ask questions and receive answers from other members of the community.

Please make sure to read Frequently asked questions and How to use this Q&A? before posting your first questions.
Social login is currently unavailable. If you've previously logged in with a Facebook or GitHub account, use the I forgot my password link in the login box to set a password for your account. If you still can't access your account, send an email to [email protected] with your username.