The Godot Q&A is currently undergoing maintenance!

Your ability to ask and answer questions is temporarily disabled. You can browse existing threads in read-only mode.

We are working on bringing this community platform back to its full functionality, stay tuned for updates. | Twitter

0 votes

I'm working on a dark level and have a WorldEnvironment added to the scene that reflects this. It works fine while running the game, but while editing the scene I find it almost impossible to work now because I can not find a way to temporarily disable or ignore the lack of ambient light in the editor.

I would expect a visibility toggle next to the node or another such simple solution, but it is escaping me.

Godot version 3.4.4
in Engine by (15 points)

1 Answer

0 votes
Best answer

In the 3D viewport's Perspective menu, choose View Environment to make the 3D viewport ignore the WorldEnvironment. It will use the default clear color instead (which also adds some of its own ambient light). To remove this ambient light entirely, try setting the default clear color to pure black in the Project Settings.

by (12,878 points)
selected by
Welcome to Godot Engine Q&A, where you can ask questions and receive answers from other members of the community.

Please make sure to read Frequently asked questions and How to use this Q&A? before posting your first questions.
Social login is currently unavailable. If you've previously logged in with a Facebook or GitHub account, use the I forgot my password link in the login box to set a password for your account. If you still can't access your account, send an email to [email protected] with your username.