This site is currently in read-only mode during migration to a new platform.
You cannot post questions, answers or comments, as they would be lost during the migration otherwise.
0 votes

Every other application I use remember the size I last gave it and when started - uses that size. When I open Godot project, it's always maximized and I can't find any option to change that behavior. It may seem like a small thing but I use tiling and it messes up with my setup, also because what I do is plugin development so I open and close the engine daily many times...

Godot version 3.5
in Engine by (21 points)

1 Answer

0 votes

There are CLI options I believe you can set in your shortcut / terminal:

-w windowed mode.
-r WxH sets window size
-p XxY sets window pos

eg. -r 100x100 -p 100x100

by (2,159 points)

doesn't work :(

Welcome to Godot Engine Q&A, where you can ask questions and receive answers from other members of the community.

Please make sure to read Frequently asked questions and How to use this Q&A? before posting your first questions.
Social login is currently unavailable. If you've previously logged in with a Facebook or GitHub account, use the I forgot my password link in the login box to set a password for your account. If you still can't access your account, send an email to [email protected] with your username.