This site is currently in read-only mode during migration to a new platform.
You cannot post questions, answers or comments, as they would be lost during the migration otherwise.
0 votes

I know how to scale sprites without losing the quality -> Reimport. However, I'm using a TileMap for a background, and I want to scale that to 4x the size(because I scaled my Player to that size, and reimported it)

How can I reimport images into a tilemap without degrading the quality? There's an option for single sprites, but I can't see anything for TileMaps.

Godot version 3.4.2 (stable official)
in Engine by (20 points)

Could you upload a screenshot or two of the scaled-up TileMap being used as your background? As an experiment, I tried to replicate what I think you're running into in a sample project. Using an incredibly small (30x5 pixels) graphic I had lying around, I tried seeing if turning the Filter option in the import settings for this graphic would have any effect on the cells that have been drastically scaled up.

Here's the graphic I'm using for the TileMap:
enter image description here
(So small!)

Here's a screenshot of the scene using the graphic with Filter turned on:
enter image description here

Here's a screenshot of the scene using the graphic with Filter turned off:
enter image description here

I up-scaled my cell size to 32 times their original size so it'd fit nicely in a default 2D project space.
Notice how the super up-scaled graphic looks awfully blurry with Filter turned on. But then, turning Filter off gives us sharp pixels.

"Works on my machine" is never a satisfying answer so I feel like I'm not fully understanding your problem yet.

Hello, I'll attach an image now, I meant to do that earlier.

Your first image is exactly what I have there. I don't know how to turned off the filter. It seems as if you went to the import tab. But what I go there, it's just an empty area

1 Answer

0 votes

I just realised my problem. I wanted to reimport my tileset with the filter turned off so that there was no blurring. However, when my TileMap was selected, I went to the import tab and nothing was there. I realised that I'm supposed to select the actual image file from the file explorer at the bottom, and re-import that.

Thank you so much for trying to help. Incredibly appreciated. :)

by (20 points)

Ah, easy mistake! Glad you figured it out!

Welcome to Godot Engine Q&A, where you can ask questions and receive answers from other members of the community.

Please make sure to read Frequently asked questions and How to use this Q&A? before posting your first questions.
Social login is currently unavailable. If you've previously logged in with a Facebook or GitHub account, use the I forgot my password link in the login box to set a password for your account. If you still can't access your account, send an email to [email protected] with your username.