This site is currently in read-only mode during migration to a new platform.
You cannot post questions, answers or comments, as they would be lost during the migration otherwise.
0 votes


i am struggeling in Godot 4.0 with this problem:

I want the Texture of a Sprite2D not to strecht while scaling. Instead, I want the texture to repeat like this:

top: how it should be, bottom: how it is
top: how it should be, bottom: how it is

I tried the option under "Texture" for "Reapeat", but it did nothing.

Godot version 4.0 stable dotnet
in Engine by (39 points)

1 Answer

+1 vote
Best answer

On your Sprite2D node, make the following adjustments in the inspector:

  • Set Texture | Repeat to enabled
  • Set Region | Enabled to on
  • Adjust Region | Rect values as necessary to position and size the result
by (22,704 points)
selected by
Welcome to Godot Engine Q&A, where you can ask questions and receive answers from other members of the community.

Please make sure to read Frequently asked questions and How to use this Q&A? before posting your first questions.
Social login is currently unavailable. If you've previously logged in with a Facebook or GitHub account, use the I forgot my password link in the login box to set a password for your account. If you still can't access your account, send an email to [email protected] with your username.