The Godot Q&A is currently undergoing maintenance!

Your ability to ask and answer questions is temporarily disabled. You can browse existing threads in read-only mode.

We are working on bringing this community platform back to its full functionality, stay tuned for updates. | Twitter

0 votes

I have a CollisionShape2D that I am using an AnimationPlayer with keyframes set on scaling from (0, 0) to (1,1) in 1s. I'm using it similar to an explosion and it uses an animation to give the player time to dodge the explosion. The problem is it seems to be way larger than I expect it to be when it's scaled but it's hard to tell since I cannot actually see the shapes interact.

Is there a way enable some sort of out line for all the CollisionShapes to get more visual feedback of what is happening to help with debugging?

in Engine by (15 points)

You must not scale CollisionShapes! Instead, change the shape's radius property.

I knew this but couldn't find it at first. Finally find how to keyframe it in the actually shape's properties.

1 Answer

0 votes
Best answer

You can turn on this option.

enter image description here

by (618 points)
selected by
Welcome to Godot Engine Q&A, where you can ask questions and receive answers from other members of the community.

Please make sure to read Frequently asked questions and How to use this Q&A? before posting your first questions.
Social login is currently unavailable. If you've previously logged in with a Facebook or GitHub account, use the I forgot my password link in the login box to set a password for your account. If you still can't access your account, send an email to [email protected] with your username.