This site is currently in read-only mode during migration to a new platform.
You cannot post questions, answers or comments, as they would be lost during the migration otherwise.
+2 votes

I've a model of about 9000 vertices and about 17000 edges. When i use godot in non rendering mode, still it lags.

i've played games which contain over 100,000 to 200,000 poly at a time on screen and those use OpenGL 2 too.

i don't see any remarkable error on the console shell.
Any advice to reduce lag, and use high poly at a time as they are done in Unity and Unreal Engine?

any help will be appreciated... :)

Using, windows 7 32 bit
4 gb ram (only 1.55 used by system)
Intel R graphics card which supports opengl 2
using Godot 2.1.4 (stable)
processor i3 intel, 370m 2.40 GHz

Note:- games such as nfs MW, igi, grand theft, run fine on my system, about 25 - 35 fps

in Engine by (65 points)

25-35 fps on these games is slow so the editor may be using a lot of the system resources, remember that Godot editor is "made in Godot" unlike other tools.

Try changing the mode Godot is updating (the spinning wheel on the top right) and the Renderer values to lower ones in project settings.

1 Answer

0 votes

I think this may be better addressed on the Godot issues section on Github.

They may be able to point out if there is some good reason why it's slower and maybe even include it as a test for improving the models performance in updates to Godot.

by (89 points)
Welcome to Godot Engine Q&A, where you can ask questions and receive answers from other members of the community.

Please make sure to read Frequently asked questions and How to use this Q&A? before posting your first questions.
Social login is currently unavailable. If you've previously logged in with a Facebook or GitHub account, use the I forgot my password link in the login box to set a password for your account. If you still can't access your account, send an email to [email protected] with your username.