This site is currently in read-only mode during migration to a new platform.
You cannot post questions, answers or comments, as they would be lost during the migration otherwise.
0 votes

Hi I was wondering if there is an easy way to disable the visibility of background panel of the button when it is set to 'flat' and the mouse hovers over it

I am drawing my own button background with the patch9 node anyways- when the button is focused however - the flat effect doesnt work. I want my button to stay flat in both focused and non focused states

in Engine by (100 points)

1 Answer

0 votes

nevermind, I figured it out

Just set a style override

by (100 points)

I need help with this. Can you please be more specific about this? It ruins my button color when I hover the mouse

I was searching for an answer to this question. When i found this i was like.... "someone finally asked the question." But the answer was a bit vague.

So to be specific cause I was kinda confused by this as well.......... go into your buttons inspector/ control/ custom styles...……. enable "focus" or any other of the 5 options and set "null" too "style-box-empty.

This gets rid of the annoying box that's visible in the back or front.

How though...

Welcome to Godot Engine Q&A, where you can ask questions and receive answers from other members of the community.

Please make sure to read Frequently asked questions and How to use this Q&A? before posting your first questions.
Social login is currently unavailable. If you've previously logged in with a Facebook or GitHub account, use the I forgot my password link in the login box to set a password for your account. If you still can't access your account, send an email to [email protected] with your username.