This site is currently in read-only mode during migration to a new platform.
You cannot post questions, answers or comments, as they would be lost during the migration otherwise.
0 votes

So, I've finally got a mini game to work in Godot 3.0, beta 1, but when I decide to use One Click Deploy, it doesn't work at all... It finishes the "Exporting for Android", shortly after, so does the "Running on Samsung SM-T350", yet, to no avail.

I have USB Debugger enabled on my Android Device (SM-T350), Which is version 6.0.1, and I have got my JDK, ADB and my debug.keystore.

Using Windows 8

in Engine by (164 points)

run godot tool in cmd and see what error says.

How would I do this?

run cmd as following instruction below.

go to directory which contains godot.exe
run godot.exe

I've run it succesfully in the cmd, here's the pastebin:

1 Answer

0 votes

you got this error.
you need to set proper Debug keystore at Editor Settings > Export > Android.

you can use your own keystore / user / pass for debug.

by (9,800 points)

I've done this, yet to no avial. Here is what my paths look like:

Welcome to Godot Engine Q&A, where you can ask questions and receive answers from other members of the community.

Please make sure to read Frequently asked questions and How to use this Q&A? before posting your first questions.
Social login is currently unavailable. If you've previously logged in with a Facebook or GitHub account, use the I forgot my password link in the login box to set a password for your account. If you still can't access your account, send an email to [email protected] with your username.