I'm working on a quite complext game, and trying to implement the game logic to control the different behaviors of the player depending on different combinations of inputs.
if is_key_pressed and another_key_pressed:
do another stuff
do other stuff
It have lots of this structures, but worse, with ifs inside ifs, and seems messy, and I feel that should exist a better way to do that.
I think this is a question about design, but i'm new to godot so I cound't figure out how to deal with it.