The Godot Q&A is currently undergoing maintenance!

Your ability to ask and answer questions is temporarily disabled. You can browse existing threads in read-only mode.

We are working on bringing this community platform back to its full functionality, stay tuned for updates. | Twitter

+1 vote

I am having a lot of trouble figuring out how to consistently turn off the filter so my pixel art isn't blurry. I'm using the Tiled importer. I have read all the posts I can find on the subject, but obviously I'm missing something.

In project settings, there are two checkboxes for filter. Do both of these need to be unchecked for the filter to turn off? Godot does not save this setting, so I have to do this manually every time I use the program.

When I import the tileset the tiles are filtered. Examining the tiles, the flags are all off and the image is uncompressed. I tried importing a .tex with mipmaps and filter off and manually changing the resource from the .png to the .tex in every tile (undesirable, but at this point I'll take what I can get). It sometimes appears to work in the editor, but when I run the scene the tiles are still blurry.

Is there some way to permanently turn off the filter? I have one map that is unfiltered but I've been unable to replicate it after many attempts. All the other maps are filtered.

There are a lot of things I like about Godot, but working with tilemaps has become very tedious.

in Engine by (31 points)

Usually, turning off filter and gen_mipmaps in Image Loader should do the trick for pixel art (before you do this per image of course, because it's a default option). In the options panel, make sure you uncheck the boxes on the right (really, not the left one :p).

1 Answer

+2 votes
Best answer

I'm not sure what I was doing before, but the solution is to import a texture and change the tileset resource to that texture.

After importing the Tiled map go to Import > 2D Texture and create a texture for the tileset, uncompressed, no mipmaps, no filter. Select the tilemap node in the Editor, and through the Inspector go Tileset > Texture > Resource and change the path and filename to the .tex file.

This maps for ALL the tiles using that sheet, thankfully.

by (31 points)
Welcome to Godot Engine Q&A, where you can ask questions and receive answers from other members of the community.

Please make sure to read Frequently asked questions and How to use this Q&A? before posting your first questions.
Social login is currently unavailable. If you've previously logged in with a Facebook or GitHub account, use the I forgot my password link in the login box to set a password for your account. If you still can't access your account, send an email to [email protected] with your username.