The Godot Q&A is currently undergoing maintenance!

Your ability to ask and answer questions is temporarily disabled. You can browse existing threads in read-only mode.

We are working on bringing this community platform back to its full functionality, stay tuned for updates. | Twitter

0 votes

So I imported a large .png image from Inkscape to Godot. Now the image imports fine but when I scale it down. It's a little blurry or pixelated. Is there any fix for this?

in Engine by (208 points)

1 Answer

+1 vote

Turn mipmaps and filtering off. You can do this by double clicking the image, then go to Import settings.

by (1,492 points)

I tried that. Mipmap was already off. Filtering off didn't change much.

Do you know how to change the size of image without stretching or scaling. So that even when you zoom out it's not overly blurry. Because I exported large sprites that are bigger than the viewport but I scaled it down.

Welcome to Godot Engine Q&A, where you can ask questions and receive answers from other members of the community.

Please make sure to read Frequently asked questions and How to use this Q&A? before posting your first questions.
Social login is currently unavailable. If you've previously logged in with a Facebook or GitHub account, use the I forgot my password link in the login box to set a password for your account. If you still can't access your account, send an email to [email protected] with your username.