This site is currently in read-only mode during migration to a new platform.
You cannot post questions, answers or comments, as they would be lost during the migration otherwise.
+2 votes

I'm trying to follow this tutorial But I'm super stuck with some basic questions.

one of the instructions says:

"Open the newly created Spatial Material and scroll down to the
“Albedo” section and click beside the “Texture” property to add an
Albedo Texture. Here we will apply the texture we made. Choose “New

but when I press "New ViewportTexture" in the albedo I get the following messages

"Can't create a viewport texture on this resource because it's not set
as local to scene. please switch on the "local to scene" property on
it (and all resources containing it up to a node)"

So how do I set this as local to the scene?
I don't know if this is the right place to make specific questions about the documentation. sorry if this is not the place

in Engine by (137 points)

Trust me, you're in the right place. ;) However, I don't know how to solve your problem. It could be a setting for the Viewport. Have you looked at the properties of the Viewport in the Inspector?

1 Answer

+7 votes
Best answer

The solution was super simple!

In the material, scroll to the bottom of the inspector. It's in the "Resource" section.

Thanks to the help of the user Mewse on discord

by (137 points)

Here's an image for anybody still missing it (due to the fliter box not actually showing all items that exist):
enter image description here

Welcome to Godot Engine Q&A, where you can ask questions and receive answers from other members of the community.

Please make sure to read Frequently asked questions and How to use this Q&A? before posting your first questions.
Social login is currently unavailable. If you've previously logged in with a Facebook or GitHub account, use the I forgot my password link in the login box to set a password for your account. If you still can't access your account, send an email to [email protected] with your username.