The Godot Q&A is currently undergoing maintenance!

Your ability to ask and answer questions is temporarily disabled. You can browse existing threads in read-only mode.

We are working on bringing this community platform back to its full functionality, stay tuned for updates. | Twitter

+4 votes

I am currently following the tutorial video on Rigidbody 2D, and in the video and documentation I found on the net both says I can set bounce and friction in Inspector. But I don't see those settings. Have they been moved ?
I am using Godot 3.1 <- screen grab of the Inspector

in Engine by (177 points)
edited by

2 Answers

+2 votes

Same problem here. I solved put on the script node the methods set_bounce(value) and set_friction(value) in _ready(). Following the link documentation, case you need more information about it:

by (18 points)

Awesome, thanks. I would still like to know if it is intended or a bug.

+13 votes

In Godot 3.1, physics properties were moved to the PhysicsMaterial resource, rather than direct properties of the RigidBody2D. This is a plus, because it means you can save/share those resources between objects, but it does mean that older tutorials like the one you were watching may not be 100% accurate anymore.

You can see examples of setting the Bounce property in the PhysicsMaterial here:

by (22,191 points)

Thank you so very much to clear this up.

Welcome to Godot Engine Q&A, where you can ask questions and receive answers from other members of the community.

Please make sure to read Frequently asked questions and How to use this Q&A? before posting your first questions.
Social login is currently unavailable. If you've previously logged in with a Facebook or GitHub account, use the I forgot my password link in the login box to set a password for your account. If you still can't access your account, send an email to [email protected] with your username.