The Godot Q&A is currently undergoing maintenance!

Your ability to ask and answer questions is temporarily disabled. You can browse existing threads in read-only mode.

We are working on bringing this community platform back to its full functionality, stay tuned for updates. | Twitter

0 votes


I've downloaded this pack of sprites in Kenney:
But I've found out that there is a 1-pixel gap/spacing between every tile.

Also, I tried to use the snap function to make easier choosing between tiles, but I can't change the tileset editor's snap settings. I thought that maybe I didn't change the tilemap cell's values but I had, every tile is 16x16 px and the whole image is 1024px.

Is there a way to "skip" the gap in between? How can I change the snap settings? But the settings of the tileset editor.


in Engine by (108 points)

1 Answer

+2 votes
Best answer

Click on the "Enable snap and show grid..." button:
enter image description here

Then set the Step/x and Step/y to 16, and the Separation/x and Separation/y to 1:
enter image description here

by (1,663 points)
selected by

Thanks! That was it!

Welcome to Godot Engine Q&A, where you can ask questions and receive answers from other members of the community.

Please make sure to read Frequently asked questions and How to use this Q&A? before posting your first questions.
Social login is currently unavailable. If you've previously logged in with a Facebook or GitHub account, use the I forgot my password link in the login box to set a password for your account. If you still can't access your account, send an email to [email protected] with your username.