This site is currently in read-only mode during migration to a new platform.
You cannot post questions, answers or comments, as they would be lost during the migration otherwise.
0 votes

Why appears those "lines" between the tiles?
enter image description here

The size of each tile is 16x16.

in Engine by (177 points)

3 Answers

+2 votes

In Project Settings --> Rendering --> Quality. Turn "Use Pixel Snap" on.

I am not 100% sure but i had a similiar issue long time ago and this helped.

by (22 points)
+2 votes

This is mentioned in the Tips & Tricks section in the Godot documentation for TileMaps. Here is the relevant quote.

If you’re using a Camera2D to scroll your level, you may notice lines appearing between your tiles. To fix this, open Project Settings and enable “Use Pixel Snap” in the “Rendering/Quality” section.

Here is an image that might help you find it.
Use Pixel Snap

by (36 points)
+1 vote

Just for future people with this problem. try Importing without the filter on. my "lines" were really just a little bleed from the adjacent tiles because of the filter. I didn't event need the "use pixel snap". BTW, the "use pixel snap" setting is now in Project Settings > Quality > 2D > Snapping and is called Use GPU Pixel Snap

by (616 points)
How do you turn off the filter?
Welcome to Godot Engine Q&A, where you can ask questions and receive answers from other members of the community.

Please make sure to read Frequently asked questions and How to use this Q&A? before posting your first questions.
Social login is currently unavailable. If you've previously logged in with a Facebook or GitHub account, use the I forgot my password link in the login box to set a password for your account. If you still can't access your account, send an email to [email protected] with your username.