This site is currently in read-only mode during migration to a new platform.
You cannot post questions, answers or comments, as they would be lost during the migration otherwise.
+7 votes

When you duplicate a node then changing one changes the other, how can I prevent that?

in Engine by (455 points)

How are you initially creating the (first) node? is it another scene that your are instancing?

I first create the node, then duplicate it by right clicking

2 Answers

–4 votes

This behavior is only when i instance the nodes.
When duplicating (Control + D ??) it should not happen.

But you can clear inheritance.
Right click on the node in scence tree "Clear Inheritance"

by (22 points)

I don't see such an option when I PPM a node.

+9 votes

Select your duplicated node then in the inspector click on the little tool icon and select "Make Sub-Resources Unique". You have to do that also for all child nodes.

by (1,476 points)

That works. That's good that I had just 4 nodes in my duplicated tree. I don't really like this feautre, it's not very intuitive.

Thanks! This helped me a lot!

Welcome to Godot Engine Q&A, where you can ask questions and receive answers from other members of the community.

Please make sure to read Frequently asked questions and How to use this Q&A? before posting your first questions.
Social login is currently unavailable. If you've previously logged in with a Facebook or GitHub account, use the I forgot my password link in the login box to set a password for your account. If you still can't access your account, send an email to [email protected] with your username.