The Godot Q&A is currently undergoing maintenance!

Your ability to ask and answer questions is temporarily disabled. You can browse existing threads in read-only mode.

We are working on bringing this community platform back to its full functionality, stay tuned for updates. | Twitter

+1 vote

I am running on a 144 fps display but am only getting a max fps of 30 (even with godot's pre-made games). I have tried setting Force Fps in the project settings to 0 and to a number larger than 30, but either way I get 30 fps. It is like this when running the game in the godot editor and after export. How can I increase or remove the fps cap of 30? (for a 2D game)

in Engine by (46 points)
edited by

2 Answers

+3 votes
Best answer

For 3D games, I know this can be toggled in the Project Settings, under Display -> Window -> Use Vsync. Disabling VSync skyrockets my FPS from 60 to ~2,500. It may be the same for 2D.

by (176 points)
selected by

I have done as you mentioned.

0 votes

If you are getting 30 fps locked on a 144 Hz display that could be a problem with your
display cable.

First of all, it should be a HDMI or DisplayPort cable, not a VGA-cable.

If you get more than 30 fps in other games and apps then it is not a cable problem obviously.

by (140 points)
Welcome to Godot Engine Q&A, where you can ask questions and receive answers from other members of the community.

Please make sure to read Frequently asked questions and How to use this Q&A? before posting your first questions.
Social login is currently unavailable. If you've previously logged in with a Facebook or GitHub account, use the I forgot my password link in the login box to set a password for your account. If you still can't access your account, send an email to [email protected] with your username.