This site is currently in read-only mode during migration to a new platform.
You cannot post questions, answers or comments, as they would be lost during the migration otherwise.
0 votes

When I try to use the screen reading node in the shader editor it shows as a 100% black material.![enter image description here]

Here is a screenshot + the shader used
enter image description here

in Engine by (34 points)

1 Answer

0 votes

After carefully checking I discovered the issue. The mesh when reimported in Godot 2.1 had shadow casting enabled and unshaded disabled. So it caused the issue.

When the proper flag where enabled everything worked just fine.
I think it should be included in the documentation or somewhere as a reference for people with a similar problem.

by (34 points)
Welcome to Godot Engine Q&A, where you can ask questions and receive answers from other members of the community.

Please make sure to read Frequently asked questions and How to use this Q&A? before posting your first questions.
Social login is currently unavailable. If you've previously logged in with a Facebook or GitHub account, use the I forgot my password link in the login box to set a password for your account. If you still can't access your account, send an email to [email protected] with your username.