This site is currently in read-only mode during migration to a new platform.
You cannot post questions, answers or comments, as they would be lost during the migration otherwise.
+1 vote

ERROR: RSET 'replblend' is not allowed on node /root/mainworld/1 from: 1. Mode is 0, master is 1.

This error presents itself when I try and set a puppet variable in my player script, in an if(isnetworkmaster()) block. I have two other puppet variables called replposition and replrotation, which work fine and positions and translations are synced over the network.

Now when I try and manipulate "repl_blend", which is a variable which I use to set a parameter in an Animationtree, that error get's thrown a bunch and animations are not fixed. The error only happens on the client that joins, not the server, but there animations are also not synced.

I can send my code if neccesary.
Can anyone help? Thanks!

in Engine by (13 points)

1 Answer

0 votes

did you set the variable as remote setable with

rsetconfig("replblend", MultiplayerAPI.RPCMODEREMOTE)

by (71 points)
Welcome to Godot Engine Q&A, where you can ask questions and receive answers from other members of the community.

Please make sure to read Frequently asked questions and How to use this Q&A? before posting your first questions.
Social login is currently unavailable. If you've previously logged in with a Facebook or GitHub account, use the I forgot my password link in the login box to set a password for your account. If you still can't access your account, send an email to [email protected] with your username.