The Godot Q&A is currently undergoing maintenance!

Your ability to ask and answer questions is temporarily disabled. You can browse existing threads in read-only mode.

We are working on bringing this community platform back to its full functionality, stay tuned for updates. | Twitter

0 votes


I am importing an image to Godot by drag&drop into the FileSystem, then i drag&drop my image from FileSystem into the Texture property of the Albedo category of my material.
When i do this the image imports again, here is a picture of it happening:
image looking has expected
and here is a picture of it after import finishes:
image gained a pattern of semi transparent colored squares

I think this might be because of the image being compressed to DXT1, is there any way to change the compression? or is this completely unrelated to DXT compression?

in Engine by (22 points)

1 Answer

+3 votes

I'm not sure if i'm allowed to answer my own question, but i found a solution and just wanted to share in case anyone has the same problem.

After importing an image you can select it in the FileSystem, and then on the side of the Scene tab there is an Import tab you click it and you get access to a bunch of import options. You can't directly choose the imported format but you can choose if the image gets compressed or not under Mode property of the Compress category. In my case changing this option from VRAM Compressed to VRAM Uncompressed and clicking the button Reimport solved my issue.

by (22 points)

Thanks ! Your answer help me to chnage the default RGBA DXT5 compression that do not work for GLES2.0. Setting it with Lossless compression works.

Welcome to Godot Engine Q&A, where you can ask questions and receive answers from other members of the community.

Please make sure to read Frequently asked questions and How to use this Q&A? before posting your first questions.
Social login is currently unavailable. If you've previously logged in with a Facebook or GitHub account, use the I forgot my password link in the login box to set a password for your account. If you still can't access your account, send an email to [email protected] with your username.