0 votes

My scene is 400*225 px and then upscaled to 1280x720 with the Test Width/Height setting in project settings, to make it look pixelated.

I have a shader on an object which makes it sway back and forth. I want the distortion to have the same resolution as the rest of my assets, however it seems the effect is applied after the upscaling, making it appear to have a higher resolution than the rest of the game. Can I either A. make sure the shader is run before the upscaling, or B. force the shader to be of a "lower" resolution then it is. Or C. something else completely.

I have the "Stretch" setting set to 2D, or the shader wont work. "Hidpi" is off.

in Engine by (57 points)

using "shrink" might work better?
you can use the "shrink" viewport setting to pixelate or upscale the whole game (in settings window) or individual viewports in the viewport container properties

Please log in or register to answer this question.

Welcome to Godot Engine Q&A, where you can ask questions and receive answers from other members of the community.

Please make sure to read Frequently asked questions and How to use this Q&A? before posting your first questions.
Social login is currently unavailable. If you've previously logged in with a Facebook or GitHub account, use the I forgot my password link in the login box to set a password for your account. If you still can't access your account, send an email to [email protected] with your username.