The Godot Q&A is currently undergoing maintenance!

Your ability to ask and answer questions is temporarily disabled. You can browse existing threads in read-only mode.

We are working on bringing this community platform back to its full functionality, stay tuned for updates. | Twitter

0 votes

Here's a video of my problem
The hexagonal (and boringly untextured) meshes seem to be culling themselves based on how many are currently visible. I can't find references to this maximum or any advice on how to modify it. Suggestions?
MultiMeshInstance is off the table in this circumstance, since each MeshInstance will need to render a different set of materials for each of its 18 surfaces (you can see the surface polygons fade in & out if you watch closely)
EDIT: it may be relevant, the map image is applied to a plane, which then has a next pass shader applied to it that forces transparency // EDIT2: not relevant, I disabled that mesh in the scene tree and the problem continued.

in Engine by (749 points)
edited by

1 Answer

+1 vote
Best answer

Project Settings>General>Rendering>Limits>Max Renderable Elements
Not sure how I missed that.

by (749 points)
Welcome to Godot Engine Q&A, where you can ask questions and receive answers from other members of the community.

Please make sure to read Frequently asked questions and How to use this Q&A? before posting your first questions.
Social login is currently unavailable. If you've previously logged in with a Facebook or GitHub account, use the I forgot my password link in the login box to set a password for your account. If you still can't access your account, send an email to [email protected] with your username.