The Godot Q&A is currently undergoing maintenance!

Your ability to ask and answer questions is temporarily disabled. You can browse existing threads in read-only mode.

We are working on bringing this community platform back to its full functionality, stay tuned for updates. | Twitter

+1 vote

When the screen is at the default window size (Which for reference is around 640 x 640), the rigid bodies seem to act normal.

However, when you resize the screen, the rigid bodies suddenly disappear.
When you expand the window down, you can see that they've somehow been pushed downwards.

Here are some images for more reference (just go to the links):

when at default window size
when window is resized
when we expand the window down

Any help on how to fix this will be greatly appreciated!

in Engine by (38 points)

1 Answer

0 votes

In Project -- Project Settings , in Display -- Window option , go at the bottom and select Mode as 2d and aspect as keep.

Also ,check that your RigidBody2D is inside the blue frame (camera view) .

by (113 points)
Welcome to Godot Engine Q&A, where you can ask questions and receive answers from other members of the community.

Please make sure to read Frequently asked questions and How to use this Q&A? before posting your first questions.
Social login is currently unavailable. If you've previously logged in with a Facebook or GitHub account, use the I forgot my password link in the login box to set a password for your account. If you still can't access your account, send an email to [email protected] with your username.