The Godot Q&A is currently undergoing maintenance!

Your ability to ask and answer questions is temporarily disabled. You can browse existing threads in read-only mode.

We are working on bringing this community platform back to its full functionality, stay tuned for updates. | Twitter

0 votes

I in the 2D game tutorial, near the end, adding audio. I added both the ongoing background music, and the Game Over sound. What puzzles me is why the background music repeats forever while the Game Over sound is one-time. I did not find or click a [ ] loop checkbox anywhere. There is no gd script code to make the one loop.

How does Godot know to loop the one and not the other?

Perhaps an explanation could be added to the tutorial page.

in Engine by (18 points)

1 Answer

+5 votes
Best answer

Looping is an import property of the audio resource. To change it you need to go to the "Import" tab.

OGG files are imported with looping enabled by default, and wav files import without by default.

by (22,191 points)
selected by

Where I can change these default settings?

Lebostein: As of Godot 3.3, you can change the default audio settings using the Import Defaults tab in the Project Settings.

Note that looping is always enabled for WAV files if they contain loop points. If this is a problem, you can use third-party tools such as Audacity to remove loop points from the WAV file.

Welcome to Godot Engine Q&A, where you can ask questions and receive answers from other members of the community.

Please make sure to read Frequently asked questions and How to use this Q&A? before posting your first questions.
Social login is currently unavailable. If you've previously logged in with a Facebook or GitHub account, use the I forgot my password link in the login box to set a password for your account. If you still can't access your account, send an email to [email protected] with your username.