This site is currently in read-only mode during migration to a new platform.
You cannot post questions, answers or comments, as they would be lost during the migration otherwise.
0 votes

I'm attempting to run the /godot-demo-projects/tree/master/networking/webrtc_signaling project on my headless build. I have successfully integrated the godotengine/webrtc-native plugin when running non-headless, and already solved the first issue of the webrtc.tres file not having a Server platform specific path, but I'm now getting the following error when trying to run:

ERROR: open_dynamic_library: Condition "!p_library_handle" is true. Returned: ERR_CANT_OPEN
   At: drivers/unix/os_unix.cpp:426.

I'll admit, I'm slightly confused as to whether webrtc-native is a plugin vs a module (very new to Godot, sorry, still getting a hold on everything), so I'm not sure if this is another Project setting I'm missing prior to exporting my .pck file, or another build option/config change I need on my headless build. I've found some references to GDNative and headless not playing together, but they reference making changes to a .gdnlib file similar to what I made to the .tres file, and I'm not seeing that, again unsure whether we're talking project vs engine settings here

in Engine by (16 points)

1 Answer

0 votes

Someone on the discord ended up answering this for me. The problem was that the *.so file that is part of the webrtc-native build needs to be placed alongside of the headless server executable with the *.pck file. As of right now, I don't know how to bundle the plugin into my server build itself, but the workaround will do.

by (16 points)
Welcome to Godot Engine Q&A, where you can ask questions and receive answers from other members of the community.

Please make sure to read Frequently asked questions and How to use this Q&A? before posting your first questions.
Social login is currently unavailable. If you've previously logged in with a Facebook or GitHub account, use the I forgot my password link in the login box to set a password for your account. If you still can't access your account, send an email to [email protected] with your username.