The Godot Q&A is currently undergoing maintenance!

Your ability to ask and answer questions is temporarily disabled. You can browse existing threads in read-only mode.

We are working on bringing this community platform back to its full functionality, stay tuned for updates. | Twitter

0 votes

How to get the issue:
- Disable V-Sync or have the physics FPS higher than 60. (300, for example.)
- Start the game.

Whenever I move the mouse, the whole game lags. This is true to my whole desktop. After I booted up the game and move my cursor, the movement becomes slow and jittery.

This is specifically a Linux issue, and it's tied to FPS. If somebody can help me resolve the issue, I would be really grateful.

The FPS itself is not low. It's about 1300-1500 while playing.

Video of the issue.

in Engine by (64 points)
edited by

1 Answer

0 votes
Best answer

This is probably because the high GPU usage overwhelms the system. It's why using V-Sync or setting a FPS limit is recommended most of the time :)

Likewise, it's highly recommended to have some kind of FPS cap when recording a video to avoid dropped frames in the resulting video.

Also, consider disabling compositing or a non-compositing window manager to improve gaming performance on Linux.

by (12,878 points)
selected by
Welcome to Godot Engine Q&A, where you can ask questions and receive answers from other members of the community.

Please make sure to read Frequently asked questions and How to use this Q&A? before posting your first questions.
Social login is currently unavailable. If you've previously logged in with a Facebook or GitHub account, use the I forgot my password link in the login box to set a password for your account. If you still can't access your account, send an email to [email protected] with your username.