The Godot Q&A is currently undergoing maintenance!

Your ability to ask and answer questions is temporarily disabled. You can browse existing threads in read-only mode.

We are working on bringing this community platform back to its full functionality, stay tuned for updates. | Twitter

+3 votes

Output and Debugger print nothing in Godot.
I try to write wrong codes. Godot won't stop in debugger, but skip the error and continue to run the project.
I think the problem just like this one.
enter image description here

No debugport and remote port properties in the Debug section. I tried to add them into engine.cfg but didnt work.

I've tried thing like:
1. reinstalling
2. restart my Mac
3. using steam version
4. delete config files
5. start new project
6. open demos

Any solutions?
Thank you.

in Engine by (15 points)
edited by

Did you check Debug Host value at Settings > Editor Settings > Network?

it's value is zero. In setting file is network/debug_host = "". Is it the default value? Thank you.

It must have value, like
Debugger works on network.
Did you see any option for network value?

My Mac connect to network and there are options now.
I changed the IP address but it didnt work.

is IP local address?

yes 192.x.x.x

Maybe it's the port. Go to the Project Settings and in the Debug section change the debug_port and remote_port to some other number (both properties must share the same number though). If that works, it's likely that some other application is using the default port (I had this issue with Dropbox once).

No debug_port property in the Debug section. And I tried to add them into engine.cfg and changed values liked what you said. But it didnt work. Thank you.

The debug_port info is not in engine.cfg.
It should be in ~/.godot/editor_settings.tres

There are four properties in Debugger section. And I also checked the editor_setting.tres and add debug_port but not working. Is it the format´╝č

It is in engine.cfg (not by default though, but it shows in Project Settings), at least in the 2.1 version.

I thought wrong. sorry for that. I thought it was file server port.
@vnen I'm looking at Project Setttings > Debug.
but I can't find port things.

I have them. However, I noticed they only appear after you play the project once.

Change the debug port in Scene -> Project Settings -> Debug !

We should raise this as an issue - very confusing ...

It is not really an issue because it works most of the time for everyone. This is only a problem if the port is already in use by another program.

2 Answers

+2 votes

Since this problem bugged me for a while now:

This clue got it for me: "Debugger works on network."
For me, it was the firewall. I use Window Firewall Control and disabled Godot Engine. That 'swallowed' the output.

Adding Godot to the exceptions and output works just fine.

by (37 points)
+1 vote

enter image description here

by (545 points)

My debug host was already at
I changed the port
Godot is allowed through the firewall.
Still can't get any output (should work via Debug.WriteLine?). Any other ideas? thanks.

Welcome to Godot Engine Q&A, where you can ask questions and receive answers from other members of the community.

Please make sure to read Frequently asked questions and How to use this Q&A? before posting your first questions.
Social login is currently unavailable. If you've previously logged in with a Facebook or GitHub account, use the I forgot my password link in the login box to set a password for your account. If you still can't access your account, send an email to [email protected] with your username.