The Godot Q&A is currently undergoing maintenance!

Your ability to ask and answer questions is temporarily disabled. You can browse existing threads in read-only mode.

We are working on bringing this community platform back to its full functionality, stay tuned for updates. | Twitter

0 votes

I made a 3D model on Crocotile3D, and it looks fine there and when imported to Blender.

However, when I import it to Godot Engine the textures look blurry and really weird and ugly. I've tried deactivating the filter (and that actually works) but, for some reason, it won't let me SAVE the changes to the textures. Can someone help me out? I want my 3D model to look crisp and sharp like in Crocotile3D or Blender. Thank you.

Godot version Version 3.2.3
in Engine by (12 points)

What file formats (e.g. *.obj, *.gltf) have you exported from Crocotile3D and have tried importing into the engine?

it was a GLB. file!

Have you tried exporting the model to another file format? (Can that even be done with Crocodile3D?)

Yes, I have, but I've been told that the best exporting format is .GLB

1 Answer

–1 vote

Mmm... It's really interesting. I know for this situation need to use the filter 2d Pixel for all textures in the import tab. To make the 3d scene see these textures you can also try to tick Detect 3D option.
When you change the texture filter it doesn't save to texture it saves to the .import file. So it applies only to Godot. Maybe I don't understand something.

by (55 points)
Welcome to Godot Engine Q&A, where you can ask questions and receive answers from other members of the community.

Please make sure to read Frequently asked questions and How to use this Q&A? before posting your first questions.
Social login is currently unavailable. If you've previously logged in with a Facebook or GitHub account, use the I forgot my password link in the login box to set a password for your account. If you still can't access your account, send an email to [email protected] with your username.