This site is currently in read-only mode during migration to a new platform.
You cannot post questions, answers or comments, as they would be lost during the migration otherwise.
0 votes

I have a very simple shader that just sets the normal to:

NORMAL = normalize(vec3(-1, 0, 1)); 

when I enable lighting, it has white artefacts at the edges (1 pixel, no matter how far I zoom in):

when I set the render mode to unshaded, the lines don't show up.
Any ideas how to prevent the white lines ?

this also happens when I run the scene (and enable more normals etc...):

Any ideas how to prevent this?

Godot version 3.2.4.rc4
in Engine by (41 points)

1 Answer

+1 vote

Answer my own question:

Disable anti-alias on the polygons!

by (41 points)
Welcome to Godot Engine Q&A, where you can ask questions and receive answers from other members of the community.

Please make sure to read Frequently asked questions and How to use this Q&A? before posting your first questions.
Social login is currently unavailable. If you've previously logged in with a Facebook or GitHub account, use the I forgot my password link in the login box to set a password for your account. If you still can't access your account, send an email to [email protected] with your username.